Carregando...
IDEsIntelliJJavaKotlinLinguagens de Programação

Atualizando o Gradle em um projeto no IntelliJ

Se você tem um projeto antigo em Java ou Kotlin gerado pelo IntelliJ, ele provavelmente está com a versão do Gradle desatualizada. Isso pode ser um problema para usar versões novas do Kotlin e alguns plugins.

Para atualizar o Gradle embutido no seu projeto, vá até o arquivo:

seu-projeto/gradle/wrapper/gradle-wrapper.properties

O conteúdo do arquivo provavelmente é algo assim:

distributionUrl=https\://services.gradle.org/distributions/gradle-5.2.1-all.zip
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStorePath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME

Aqui, basta você alterar o distributionUrl com o zip do Gradle da versão desejada, por exemplo:

distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-bin.zip

Depois disso, clique no icone do elefantinho do gradle com a tooltip “Load Gradle changes”. O IntelliJ baixará a nova versão do Gradle e a substituirá no projeto.

Descubra todas as versões do gradle no link:
https://services.gradle.org/distributions/

E como resolver uso de features descontinuadas agora no Gradle novo?

https://stackoverflow.com/questions/51610420/deprecated-gradle-features-were-used-in-this-build-making-it-incompatible-with

Rode o gradle build com parametros adicionais e descubra quais são os comandos do seu arquivo gradle que foram descontinuadas.

./gradlew build --warning-mode=all

Veja as recomendações e troque o que estiver descontinuadas pelos comandos novos.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *